Saturday, July 15, 2006

I had an infection for almost 3 months. The results came back.

For 3 months, I've had a Klepsiella all this time and based on my tries to get urine cultures done this whole time, the Urologists would not culture or give me any antibiotics. Even though I had two catheters in me for 2 months and one left in catheter for 3 months. Even though I told them I knew I had an infection from day one, they didn't listen or care. My urine was full of junk and smelled so foul and it was green and came out like syrup. Finally I decided to go to my Primary Care Doctor to ask him to please do a culture and to put me on an antibiotic while we waited because I was getting sick to my stomach, had severe back pain, and a bad headache. There were also huge chunks of blood coming out of my Suprapubic. He agreed with me that it should have been taken care of sooner and he was sorry I was treated that way by the Urology team. The results came back with the Klepsiella infection count over 100,000. I am going to stay on the Leavaquin until my surgery on Tuesday. I feel better in the sense that I am not sick to my stomach, no more back pain, and no headache. The phantom urgency is still spiked due to ovulation so I will have to wait 2 weeks until my period comes to get some relief and we'll go from there. One month at a time. This is what can happen during the recovery time of 6 months to a year when dealing with bladder removal. You have to be ready for anything. It just sucks when doctors don't listen to their patients.